• Home
  • ข่าวจูมล่า

Joomla! 3.8.2 ออกมาอัปเดตเรื่องความปลอดภัย

 

จูมล่า! 3.8.2 ออกมาแก้ไขเรื่องความปลอดภัย และบัคต่างๆ ที่เกิดขึ้นใน จูมล่า! 3.8.x ถึงแม้จะเป็นเรื่องความปลิดภัยระดับปานกลางและต่ำ ผมก็แนะนำให้อัปเดตโดยทันที

มีอะไรใน Joomla! 3.8.2 ?

 Joomla! 3.8.2 cdhw-ช่องโหว่ด้านความปลอดภัยสามช่องโหว่และcdhข้อบกพร่องกว่า 90 ข้อ ได้แก่ :

ด้านความปลอดภัย

  • ความสำคัญปานกลาง - หลัก - การเปิดเผยข้อมูล LDAP (มีผลต่อ Joomla! 1.5.0 ถึง 3.8.1) 
  • ความสำคัญปานกลาง - หลัก - บายพาสการรับรองความถูกต้องสองตัว (มีผลต่อ Joomla! 3.2.0 ถึง 3.8.1) 
  • ความสำคัญต่ำ - หลัก - การเปิดเผยข้อมูล (มีผลต่อ Joomla! 3.7.0 ถึง 3.8.1) 

แก้ไขข้อผิดพลาด

  • แสดงหมวดหมู่ย่อยในรูปแบบบล็อกเฉพาะเมื่อผู้ใช้มีสิทธิ์เข้าถึง # 18408
  • แก้ไขแท็กจะถูกลบโดยการทำงานแบบแบทช์และลากและวางการจัดเรียงใหม่ # 18328
  • โมดูลการค้นหาที่ไม่แสดงในเทมเพลตหลัก # 18375
  • แก้ไขการเข้าถึง / ตรวจสอบการเข้าถึงระบบไฟล์ที่ไม่จำเป็นซึ่งทำให้เกิดปัญหาเรื่องประสิทธิภาพในฟิลด์ที่กำหนดเอง # 17893
  • แก้ไขตัวจัดการบทความแบ็กเอนด์ไม่แสดงรายการบทความในหมวดย่อยเมื่อตัวกรองประเภทใช้งานอยู่ # 18179

Screen Shot 2560 11 08 at 07.10.43

หลังจากอัปเดตบางท่านอาจได้ข้อความเตือน เกี่ยวกับ  $root_user สั้นๆคือ ระบบต้องการให้คุณไปลบ บันทัดที่มี $root_user ออกจากไฟล์ configulation.php โดยสามารถคลิ๊กได้ตรงคำว่า Select here to try to do it automatically
หากไม่ได้ให้ไปเกิดไฟล์ configulation.php แล้วหา  $root_user ลบทั้งบันทัดออกไป

Screen Shot 2560 11 08 at 07.11.52

 

Download

สำหรับติดตั้งเว็บใหม่:

Download Joomla 3.8.2
English (UK), 3.8.2 Full Package

New installation instructions and technical requirements

อัพเดตจากรุ่นเก่า:

Upgrade Packages
Joomla 3 upgrade packages

Note: Please read the update instructions before updating.

Please remember to clear your browser's cache after upgrading.

 

วิธีการอัพเดตและแก้ไขปัญหา
Database error คลิ๊ก!

 

    Tags:
  • จูมล่า! 3.8.2
  • Joomla! 3.8.2

จูมล่า! 3.8.1 ออกมาแก้บัค ของ จูมล่า! 3.8.0 แล้ว

 

พอออก จูมล่า 3.8 ก็มีบัคอยู่หลายจุด โดยเฉพาะเรื่อง รูปและ  Ldap  login ตอนนี้ทีมงาน Joomla! ได้ออก จูมล่า! 3.8.1 ออกมาแก้บัค ของ จูมล่า! 3.8.0 แล้ว

มีอะไรใหม่ใน จูมล่า! 3.8.1

Joomla! 3.8.1 ออกมาเพื่อแก้ปัญหาที่เกิดขึ้นใน  3.8.0 

  • Fix handling of image srcset attribute #17978
  • Some plugin events were triggered multiple times #18066
  • Redirect plugin not redirecting correctly #17997
  • Removed checks causing some admin menu items to be hidden #18156
  • LDAP login broken #17989

Visit GitHub for the full list of bug fixes.

Download

สำหรับติดตั้งเว็บใหม่:

Download Joomla 3.8.1
English (UK), 3.8.1 Full Package

New installation instructions and technical requirements

อัพเดตจากรุ่นเก่า:

Upgrade Packages
Joomla 3 upgrade packages

Note: Please read the update instructions before updating.

Please remember to clear your browser's cache after upgrading.

 

วิธีการอัพเดตและแก้ไขปัญหา
Database error คลิ๊ก!

 

 ที่มา https://colorpack.co.th/

    Tags:
  • จูมล่า! 3.8.1
  • Joomla! 3.8.1

จูมล่า! 3.8 ออกมาแล้ว

หลังจากรอมานาน ตอนนี้ทีมงาน จูมล่า! ได้ออก จูมล่า! 3.8 แล้วซึ่งมีการปรับปรุงมากมายกว่า 300 จุดและมี จุดใหญ่ ที่น่าในใจดังนี้

มีอะไรใหม่ใน จูมล่า! 3.8

  • New Routing System - ตอนนี้เราสามารถเอาเลข ID ออกจาก  URL ได้แล้ว
  • รองรับจูมล่า! 4 - การพัฒนา Joomla! 4 ได้ทำการเปลี่ยนแปลงบางอย่างเกี่ยวกับโครงสร้างหลักโดยการโยกย้ายคลาสเพื่อใช้ PHP namespaces ใน Joomla! 3.8 จะมีเลเยอร์การแม็พเพื่อช่วยให้นักพัฒนาสามารถใช้ชื่อคลาสเก่า ๆ ได้ในขณะที่สามารถใช้ประโยชน์จากโครงสร้างคลาสใหม่ได้ด้วย
  • การติดตั้งข้อมูลตัวอย่าง -เราสาารถติดตั้งข้อมูลตัวอย่างได้ภายหลังจากการติดตั้งเว็บไปแล้ว
  • สนับสนุนการเข้ารหัสโซเดียม - PHP 7.2 แนะนำส่วนขยายโซเดียมใหม่สำหรับการประมวลผลข้อมูลที่เข้ารหัสผ่าน polyfill ในJoomla! 3.8 ทำให้ API ใหม่นี้พร้อมใช้งานสำหรับผู้ใช้ทั้งหมดของเราก่อนที่จะอัปเกรดเป็น PHP 7.2

การแก้ไขเรื่องความปลอดภัย

  • Core - Information Disclosure in LDAP Authentication Plugin (affecting Joomla 1.5.0 - 3.7.5) More information »
  • Core - Information Disclosure in com_content Archived Articles Model (affecting Joomla 3.7.0 - 3.7.5) More information »

Download

สำหรับติดตั้งเว็บใหม่:

Download Joomla 3.8
English (UK), 3.8 Full Package

New installation instructions and technical requirements

อัพเดตจากรุ่นเก่า:

Upgrade Packages
Joomla 3 upgrade packages

Note: Please read the update instructions before updating.

Please remember to clear your browser's cache after upgrading.

 

วิธีการอัพเดตและแก้ไขปัญหา
Database error คลิ๊ก!

 

ที่มา https://colorpack.co.th/

 

    Tags:
  • จูมล่า!
  • จูมล่า! 3.8
  • Joomla! 3.8

จูมล่า! 3.7.5 ออกมาแล้ว แก้บัค 1 จุด

 

Joomla! 3.7.5 ออกมาแล้ว แก้บัค  1 จุด

Joomla! 3.7.5 ออกมา แก้ไขข้อบกพร่องสำหรับ Joomla! 3.x series! มีข้อบกพร่องเกี่ยวกับการป้องกันการติดตั้ง Joomla! 3.7.4 กับฐานข้อมูลระยะไกล

มีอะไรใน จูมล่า 3.7.5

Joomla! 3.7.5 ออกม่เพื่อแก้ไขปัญหาข้อบกพร่องใน Joomla! 3.7.4 เกี่ยวกับการดำเนินการตรวจสอบความปลอดภัยเพิ่มเติมในแอ็พพลิเคชันการติดตั้งที่ออกแบบมาเพื่อปกป้องบัญชีผู้ใช้เว็บโฮสติ้งของคุณจากการถูกโจมตีโดยผู้บุกรุกจากระยะไกล
แพทช์นี้จะเปลี่ยนไฟล์เพียงไฟล์เดียวในโฟลเดอร์การติดตั้ง

แก้ไขข้อบกพร่อง

  • Joomla! ไม่ได้ติดตั้งบนฐานข้อมูลแบบรีโมต #17248

 

Download

สำหรับติดตั้งเว็บใหม่:

Download Joomla 3.7.5
English (UK), 3.7.5 Full Package

New installation instructions and technical requirements

อัพเดตจากรุ่นเก่า:

Upgrade Packages
Joomla 3 upgrade packages

Note: Please read the update instructions before updating.

Please remember to clear your browser's cache after upgrading.

 

วิธีการอัพเดตและแก้ไขปัญหา
Database error คลิ๊ก!

 

ทีมา : https://colorpack.co.th/ 

    Tags:
  • Joomla! 3.7.5
  • จูมล่า! 3.7.5

Joomla! 3.7.1 มาแล้วอัพเดตด่วน แก้ปัญหาเรื่องความปลอดภัยระดับสูง

joomla 371

Joomla! 3.7.1 ออกมาแก้ไขปัญหาด้านความปลอดภัยระดับสูง ขอเนะนำให้อัพเดตทันที เพื่อความปลอดภัยของเว็บท่าน ในรุ่นนี้แก้ไขเรื่องความปลอดภัยและแก้บัคของ จูมล่า! 3.7.0 เท่านั้น

มีอะไรใน จูมล่า! 3.7.1

Joomla! 3.7.1 ออกมาแก้ไขปัญหาด้าความปลอดภัยระดับสูง

    Tags:
  • Joomla! 3.7.1
  • จูมล่า! 3.7.0

เตรียมตัว ประกาศความปลอดภัยที่สำคัญ Joomla! 3.7.1 กำลังออกแก้ปัญหาเร็วๆนี้

Joomla! รุ่น 3.7.1 ที่จะออกมาแก้ไขด้านความปลอดภัย ในวันพุธที่ 17 พฤษภาคมเวลาประมาณ 14:00 UTC (สามทุ่มโดยประมาณ)

Joomla! ทีม Security Strike (JSST) ได้รับแจ้งเกี่ยวกับปัญหาด้านความปลอดภัยที่สำคัญใน Joomla! หลัก เนื่องจากนี่เป็นการแก้ไขด้านความปลอดภัยระดับสูงโปรดเตรียมพร้อมที่จะอัปเดต Joomla! ของคุณเป็น Joomla! รุ่น 3.7.1 โดยจะออกมาให้ใน วันพุธที่ 17 พฤษภาคมเวลาประมาณ 14:00 UTC (สามทุ่มโดยประมาณ)

เนื่องจากเป็นเรื่องความปลอดภัยระดับสูง จึงไม่สามารถเผยแพร่รายละเอียดได้

 ที่มา https://www.joomla.org/

    Tags:
  • Joomla! 3.7.1
  • ความปลอดภัย